Pique #21: Cómo solucionar invoke-rc.d: could not determine current runlevel

Este es un error que aparece cuando usamos WSL y acá te muestro cómo "solucionarlo"


1 min de lectura
Pique #21: Cómo solucionar invoke-rc.d: could not determine current runlevel

Este es un error que aparece cuando usamos WSL y acá te muestro cómo "solucionarlo"

Hace unos días estaba queriendo instalar Telegraf en mi Ubuntu que corro en WSL2, cuando corrí el...

$ sudo dpkg -i telegraf.deb

Me encontré con este error:

invoke-rc.d: could not determine current runlevel

Googleando bastante, pude hacer andar la instalación corriéndola de la siguiente manera:

RUNLEVEL=1 sudo dpkg -i telegraf.deb

Así que cada vez que quieras instalar un paquete y te tire ese error, agrégale "RUNLEVEL=1" y listo.


baehost

SUBIR

🎉 Te has suscrito con éxito a CDUser - El Blog de Ignacio Van Droogenbroeck!
OK